27 July 2006 | 17,149 views

Serious WordPress Vulnerability/Exploit Verion 2.0.3 and Below

Check Your Web Security with Acunetix

Yes that means all versions including the current version and before, 2.0.4 has not yet been released at the current time.

An exploit has been discovered in the current release of WordPress, affecting WordPress 2.0.3 and below (including 1.5.x) that allows these subscribed users to cause some serious damage.

It’s recommended at present if you are using WordPress to disable the “Anyone can Register” option in your ‘Options’ tab.

It’s also advised you delete any unknown subscribers that haven’t commented or that you don’t know personally.

WordPress developers are aware of this flaw and hopefully it will be fixed in the 2.0.4 release which is imminent.

Leaving it open and letting people sign-up for guest accounts on your WordPress blog could lead to incredibly nasty stuff happening if anybody so desired. And trust me I am not exaggerating this. So don’t wait a second to disable this option and please relay the message.

WordPress dev team has been notified a while back and I dare hope they will soon start acting on it, if only by relaying a similar announcement through the official channel (as well as, of course, releasing a proper patch).

Source: Dr Dave

Advertisements



Recent in Exploits/Vulnerabilities:
- Rowhammer – DDR3 Exploit – What You Need To Know
- Santoku Linux – Mobile Forensics, Malware Analysis, and App Security Testing LiveCD
- Google Expands Pwnium Year Round With Infinite Bounty

Related Posts:
- WordPress 2.0.4 Released – Fixes Security Issues
- WordPress 2.0.7 Follows Hot on the Tail of WordPress 2.0.6
- WordPress 2.0.5 Trackback Vulnerability with Exploit

Most Read in Exploits/Vulnerabilities:
- Learn to use Metasploit – Tutorials, Docs & Videos - 229,609 views
- AJAX: Is your application secure enough? - 119,413 views
- eEye Launches 0-Day Exploit Tracker - 85,201 views

Advertise on Darknet

7 Responses to “Serious WordPress Vulnerability/Exploit Verion 2.0.3 and Below”