02 July 2006 | 98,157 views

Downgrade PSP v2.6 to v1.5 to play homebrew & ISO games

Acunetix Web Application Security

Dark_AleX has now shared Downgrader Test v0.5 For PSP 2.50/2.60 Firmware which, according to MANY users (including TGMG, LalaMan, Firey, and LAXitives), works 100% with PSP consoles that were upgraded to v2.50 or v2.60 Firmware. However, it will NOT work with TA-082 versions and it’s NOT recommended for users whose FACTORY/STOCK Firmware was 2.50 or 2.60.

Check out the video in action here. Unfortunately the video quality is crap but its proof that it works. This hack was just released yesterday. So to those who have upgaded their PSP to v2.6, you still can downgrade to v1.5 to be able to play homebrew games and also ISO games.

Use this to check if you have TA-082 before you continue.


Tags: ,



                

Recent in General Hacking:
- PentesterLab.com – Excercises To Learn Penetration Testing
- New eLearnSecurity Course – WAPT – Web Application Penetration Testing
- Hackers Break Into White House Military Network

Related Posts:
- PSP All Version Firmware Homebrew Hack Surfaces
- libtiff Vulnerability gives hope for a new GTA-less PSP exploit
- Play v2.71 Games on your v1.5 PSP

Most Read in General Hacking:
- 10 Best Security Live CD Distros (Pen-Test, Forensics & Recovery) - 1,129,198 views
- Hack Tools/Exploits - 572,779 views
- Password Cracking with Rainbowcrack and Rainbow Tables - 409,542 views

Low-cost VPS Hosting

32 Responses to “Downgrade PSP v2.6 to v1.5 to play homebrew & ISO games”

  1. Gouki 3 July 2006 at 1:28 am Permalink

    The news posted on SXT, the team behind the downgrader.

    also the ones responsable for the 2.0 -> 1.5 downgrader

  2. Gouki 3 July 2006 at 1:55 am Permalink

    For all of those who need a step-by-step video, PSP Hacking 101 have released their lastest episode, who focus exactly on the downgrade progress.

  3. evilfoo 3 July 2006 at 2:14 am Permalink

    If you have itunes you can subscribe to their video podcast to check all PSP related hacking stuff.

  4. husssain 16 July 2006 at 12:28 pm Permalink

    what does it mean by the game could not be started (FFFFFED3) on ver 1.5

  5. evilfoo 16 July 2006 at 12:41 pm Permalink

    It may mean that your emu software is not able to play the game. It may need a higher version emu to play the game. Trying using the new devhook v0.44 you might be able to play the game because this will even let you play v2.71 firmware games.

    http://ps2nfo.com/modules.php?name=News&file=showarticle&threadid=12958

  6. View 25 July 2006 at 5:44 pm Permalink

    Hi all,
    I bought this PSP version 2.6 and I want to downgrade it to version 1.5. How I can do it and please e-malied me on view990@hotmail.com

  7. mansa 13 August 2006 at 4:39 pm Permalink

    I bought a PSP it had version 2.5 default installed. I had also purchased metal gear acid2 it required to update to version 2.6 which i did from the game files in UMD.

    Now i am searching all the forums for a week. I have read there is a v2.5 / v 2.6 downgrader . but along with it is a WARNING that do not upgrade if you have v2.5 pr v2.6 preinstalled. SO guys can you confirm if i have any solution or should i wait for enligntened people to release a crack.

  8. Coco 15 August 2006 at 11:05 am Permalink

    I originally had a 2.01 UK/EUR PSP. I used a USA updater to version 2.6 – which successfully worked. Then I downgraded to 1.5 which was also sucessful!

  9. jack 17 August 2006 at 10:29 am Permalink

    YOU ARE GAY BASTARDS

  10. Gouki 17 August 2006 at 12:10 pm Permalink

    There are some really ‘interesting’ people around here.

    I’ll talk to ST so he starts using ‘Comment Moderation’.

  11. Ian 23 August 2006 at 1:56 pm Permalink

    guys, i checked around and someone told me that when you DOWNGRADE your version, you can NEVER upgrade it……is it true???anyone has any experience on this??

  12. ChaosPT 25 August 2006 at 3:03 pm Permalink

    hi ppl i have a quest for everyone … how i downgrade my psp … my psp version is v2.6 and i wanna 2.0 version please someone i need help !!! please its urgente !!! i dont like v2.6 i wanna 2.0 … i waiting for yours coments

  13. Gouki 25 August 2006 at 3:26 pm Permalink

    @ IAN – No. It’s not. After the downgrande, you can still upgrade to whatever you want.

    @ ChaosPT – For more information about downgrading your PSP, you can read this guide.

  14. ChaosPT 25 August 2006 at 9:31 pm Permalink

    @ Gouki i see your comment and i see the web site you send me … and i have a problem … i dont have the GTA to downgrade my psp … what i do now :S … i need some help here !!! … i waiting for yours coments ;)

  15. Gouki 26 August 2006 at 10:21 pm Permalink

    Well, I guess you’re out of luck then.

  16. ChaosPT 28 August 2006 at 10:50 pm Permalink

    hey Gouki i have a quest for you if i put the GTA on my memory Card do you think … the GTA can run ??? if run i can downgrade my PSP to 2.0 ;) … i wating for your coment !!!

  17. nam 10 October 2006 at 6:02 am Permalink

    hey anyone my psp is version 2.6 the downgrader doesnt work can someone help me please

  18. mitchell 22 October 2006 at 11:48 am Permalink

    so if you ic6001 you can downgrade without out it turning into a brick

  19. mitchell 22 October 2006 at 11:49 am Permalink

    i meant if thats on ur psp can you downgrade

  20. hobot 23 October 2006 at 4:57 pm Permalink

    Hey guys, the internet is not your personal servant, if you need help downgrading your psp, ask your mother.

    She helped me out plenty last night.

  21. will 25 October 2006 at 8:34 pm Permalink

    Hey guys tell me i have a version 2.60 and wana download it to 1.50….i have the downloader as well 2.6 to 1.5 but dont have the
    gta umd is there any easy way of doing it?or any alternative
    cheers

  22. Raven 26 November 2006 at 11:01 pm Permalink

    yo i have this Downgrader 2.50-2.60, but i can’t get it to downgrade my psp..anyone knooos wat to do?

  23. betty bull 6 December 2006 at 2:04 pm Permalink

    i want to downgrade a 2.6 to a 1.5

  24. Greg 9 December 2006 at 6:48 am Permalink

    i hav a 1.5 psp..w/ everything..devhook + more
    i was wondering if ican still buy normal games and play them

  25. Gouki 12 December 2006 at 6:05 pm Permalink

    Greg, yes you can. That’s the whole point of Devhook: Emulate the firmware so you can have homebrew and still play games.

    Good to see you’re doing the right thing; not downloading the .ISO of the Internet and play it.

  26. John 22 December 2006 at 1:17 pm Permalink

    hey guys.. i have downgraded my psp to 1.5 to be able to play ISO games but there is something going wrong and i cannot play any game stores on my memory stick.. does anybody know what is going on?

  27. Lampan 26 December 2006 at 2:34 pm Permalink

    Can anyone mail me this downgrader… I’ll be soo happy to get it… plz mail it to me at: monstret_ff@hotmail.com ty all…

  28. Lampan 26 December 2006 at 3:44 pm Permalink

    Some1 have the 1.5 system and make me the folder i need to put in root on MS… same eMail as above

  29. Cold 8 January 2007 at 8:34 am Permalink

    Greetings,

    My psp is a factory v2.5 with no gold writing in the UMD drive. I was wondering;

    1)Is my psp downgradable?
    2)Is it necessary to upgrade it to v2.6 or v2.71 then downgrade it to v1.5?

  30. nysy 8 January 2007 at 2:44 pm Permalink

    pls can someone send the 2.6 to 1.5 downgrader to me at grandautoland@yahoo.com i will really appreciate it

  31. john richardson 18 May 2007 at 9:30 am Permalink

    hey i have a psp v2.6 is there any program to put downloaded games on with out downgrading ,

    thanks

  32. Sarah 9 March 2009 at 4:37 pm Permalink

    if i downgrade from 2.6 to 1.5 so that i can play copies will i still be able to use the internet on it?